Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 22:00 UTC
Scheduled
Oman Arab Bank payment gateway team will be performing a DR drill activity on their gateway from 22:00 Hrs. UTC, 09 October 2025 to 22:00 Hrs. UTC, 10 October 2025.
During the maintenance window, customers may experience an intermittent failure into the transactions during the fail-over of activity .
Posted Oct 09, 2025 - 12:47 UTC
This scheduled maintenance affected: Acquirers/Gateways.