Delay in SMS OTP delivery for Mastercard Checkout Services
Incident Report for noon payments
Resolved
There was an issue with Mastercard Checkout Services (MACS) between 09:53 to 13:30 UTC, 25 September 2024.

During the issue, customers may have experienced delay in SMS OTP delivery.

The Mastercard team confirmed that the services have been restored and are working as expected.

Thank you for your patience and continued support.
Posted Sep 25, 2024 - 15:43 UTC
Investigating
A delay in SMS OTP delivery has been identified for Mastercard Checkout Services, starting at 09:53 hrs. UTC, 25 September 2024.

We will post further updates once we receive the same from the Mastercard team.

Thank you for your patience and continued support.
Posted Sep 25, 2024 - 13:19 UTC
This incident affected: Production Environment - Global Endpoints (Acquirers/Gateways Performance) and Production Environment - KSA Endpoints (Acquirers/Gateways Performance).