Intermittent 3DS transactions failures detected from Alrajhi bank issuer

Incident Report for noon payments

Update

We are still observing the intermittent 3DS authentication failures in transactions from Alrajhi Bank.

We will post further updates till resolution of issue.

Thank you for your patience and continued support.
Posted Aug 13, 2025 - 23:36 UTC

Identified

We have identified there is an issue in which customers are facing intermittent 3DS transaction failure from the Alrajhi Bank issuer while submitting the transactions .

We will post further updates till the restoration of the service.

Thank you for your patience and continued support.
Posted Aug 13, 2025 - 15:36 UTC

Investigating

We are observing an intermittent 3DS transaction failure from the Alrajhi Bank issuer while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Aug 13, 2025 - 11:43 UTC
This incident affects: Issuers.