Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 15, 2025 - 10:00 UTC
Scheduled
The Noon Payments team will be performing scheduled maintenance for the Saudi Arabia test environment between 10:00 Hrs. UTC - 12:00 Hrs. UTC, 15 August 2025.
During the scheduled maintenance window, customers may not anticipate any major impact while processing the requests.
Posted Aug 14, 2025 - 12:30 UTC
This scheduled maintenance affected: Noon Payments - Test (Saudi Arabia - Test).