Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 16:00 UTC
Scheduled
Mastercard teams will perform scheduled maintenance for Mastercard Gateway in the Asia Pacific Region from 16:00 Hrs. UTC to 17:00 Hrs. UTC, 26 March 2025.
During the scheduled maintenance window, customers may experience an intermittent service disruption in the application.
Posted Mar 21, 2025 - 04:21 UTC
This scheduled maintenance affected: Production Environment - Global (Acquirers/Gateways Performance).