Intermittent failure and latency detected while submitting the transactions to Mastercard Payment Gateway Service
Incident Report for noon payments
Resolved
The reported issue has been resolved in which customers may have experienced an intermittent failure and latency while submitting transactions to Mastercard payment gateway services between 19:42 - 20:26 UTC, 24 September 2024.

Mastercard team confirmed that the service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Sep 24, 2024 - 21:08 UTC
Investigating
Mastercard team investigating an issue in which customer may experience latency and failures while submitting the transactions to the Mastercard Payment Gateway Service.

We will post further updates till the resolution of the same.

Thank you for your patience and continued support.
Posted Sep 24, 2024 - 20:13 UTC
This incident affected: Production Environment - Global Endpoints (Acquirers/Gateways Performance) and Production Environment - KSA Endpoints (Acquirers/Gateways Performance).