The reported issue has been resolved in which customers may have experienced an intermittent 3ds authentication failure from Emirates NBD bank card issuer while submitting the transactions between 16:35 - 17:21 Hrs. UTC, 11 May 2025.
The service has been restored and working as expected.
Thank you for your patience and continued support.
Posted May 11, 2025 - 17:47 UTC
Monitoring
We are no longer seeing 3ds authentication failure from Emirates NBD bank card issuer while submitting the transactions.
We are continuing to monitor the issue and will post further updates till the resolution of the issue.
Thank you for your patience and continued support.
Posted May 11, 2025 - 17:34 UTC
Identified
We are observing an intermittent 3DS authentication failure in the transactions from the Emirates NBD Bank issuer.
We will post further updates till resolution of the issue.
Thank you for your patience and continued support.
Posted May 11, 2025 - 16:43 UTC
This incident affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).