The reported issue has been resolved in which customers may have experienced an intermittent failure and latency while submitting transactions to Mastercard Saudi Arabia Payment Gateway services between 10:32 - 11:30 UTC, 23 May 2025.
The Mastercard team confirmed that the service has been restored and is working as expected.
Thank you for your patience and continued support.
Posted May 23, 2025 - 12:14 UTC
Monitoring
We are no longer observing latency and failure while submitting transactions to the Mastercard Payment Gateway - Saudi Arabia.
We are continuing to monitor the issue and will advise once we receive confirmation from the Mastercard team about the restoration of services.
Thank you for your patience and continued support.
Posted May 23, 2025 - 11:47 UTC
Identified
A service disruption has been identified for Mastercard Saudi Arabia Payment Gateway.
The Mastercard team is working to resolve the issue on priority.
Customers may experience intermittent latency and error while submitting transactions to the Mastercard Payment Gateway service - Saudi Arabia.
We will post further updates from Mastercard till resolution of the issue.
Thank you for your patience and continued support.
Posted May 23, 2025 - 11:05 UTC
Investigating
We are observing intermittent failure in transactions starting at 10:32 UTC, 23 May 2025
We are currently investigating the issue.
We will post further updates till resolution of issue.
Thank you for your patience and continued support.
Posted May 23, 2025 - 10:53 UTC
This incident affected: Production Environment - Global (Acquirers/Gateways Performance) and Production Environment - Saudi Arabia (Acquirers/Gateways Performance).