The reported issue has been resolved in which customers may have experienced an intermittent failure while submitting the transactions to Mastercard payment gateway services between 14:21 - 14:52 UTC, 14 April 2025.
The Mastercard team has confirmed that the services have been restored and are working as expected.
Thank you for your patience and continued support.
Posted Apr 14, 2025 - 15:39 UTC
Investigating
We are observing intermittent failure while submitting the transactions to Mastercard payment gateway service.
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.
Posted Apr 14, 2025 - 14:34 UTC
This incident affected: Production Environment - Global (Acquirers/Gateways Performance) and Production Environment - Saudi Arabia (Acquirers/Gateways Performance).