Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2025 - 21:00 UTC
Scheduled
MADA will perform a scheduled maintenance for below entities as per mentioned time intervals:
Entity Name Start Time End Time National Bank of Kuwait 21:00 UTC, 15 May 2025 04:00 UTC, 16 May 2025 Saudi National Bank 23:00 UTC, 15 May 2025 04:00 UTC, 16 May 2025 Saudi Awwal Bank 01:00 UTC, 16 May 2025 03:00 UTC, 16 May 2025
During the scheduled maintenance window, customers may experience an intermittent failure in the ecommerce transactions.
Posted May 12, 2025 - 11:01 UTC
This scheduled maintenance affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).