Intermittent failure detected while submitting the transactions to Mastercard payment gateway services
Incident Report for noon payments
Resolved
The reported issue has been resolved in which customers may have experienced an intermittent servivce disruption while submitting the transactions to Mastercard payment gateway services in the Kingdom of Saudi Arabia (KSA) Region between 00:17 Hr. - 00:50 Hr. UTC on 21 September 2024.

Mastercard team has confirmed that the service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Sep 21, 2024 - 01:46 UTC
Investigating
Masercard team has identified an intermittent servivce disruption while submitting the transactions in Kingdom of Saudi Arabia (KSA) Region.

We will post further updates once we receive the same from the Mastercard team.

Thank you for your patience and continued support.
Posted Sep 21, 2024 - 01:00 UTC
This incident affected: Production Environment - KSA Endpoints (Acquirers/Gateways Performance).