Intermittent latency and failure while processing 3DS authentication in transactions detected by Arcot

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent latency & failure while processing 3DS authentication in transactions between 16:50 - 17:49 UTC, 26 February 2026.

Arcot team confirmed that service has been restored and working as expected.

Please refer below URL for more information
https://status.broadcom.com/services/arcot/notices/8wrsszxsojam8bow-elevated-failure-rate-for-emv3ds-challenged-transactions

Thank you for your patience and continued support.
Posted Feb 26, 2026 - 18:24 UTC

Monitoring

The Arcot team has confirmed they no longer see 3DS authentication failure in transactions.

The Arcot team continues to monitor the issue and will advise once we receive confirmation from Arcot about restoring services.

Thank you for your patience and continued support.
Posted Feb 26, 2026 - 17:55 UTC

Investigating

Arcot team has detected an intermittent latency and failure while processing 3DS authentication in transactions.

The Arcot team is currently investigating the issue on priority.

Please refer below URL for more information
https://status.broadcom.com/services/arcot/notices/8wrsszxsojam8bow-elevated-failure-rate-for-emv3ds-challenged-transactions

We will post further notification once we receive it from the Arcot team.

Thank you for your patience and continued support.
Posted Feb 26, 2026 - 17:01 UTC
This incident affected: Authentication.