The reported issue has been resolved in which customers may have experienced intermittent latency and failure while submitting the transactions to Mastercard payment gateway services- Saudi Arabia between 09:50 Hrs. - 20:30 Hrs. UTC, 27 October 2025.
Services have been restored and are working as expected.
Thank you for your patience and continued support.
Posted Oct 27, 2025 - 21:55 UTC
Update
We are still observing intermittent latency and failure while submitting the transactions to Mastercard payment gateway services- Saudi Arabia
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.
Posted Oct 27, 2025 - 14:29 UTC
Investigating
We are observing intermittent latency and failure while submitting the transactions to Mastercard payment gateway services- Saudi Arabia
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.