Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 19, 2025 - 21:00 UTC
Scheduled
Neoleap payment gateway has a planned maintenance activity from 21:00 UTC, 19 May 2025 to 05:00 UTC, 20 May 2025.
During the scheduled maintenance window, customers may experience fluctuation in online transactions and payment gateway services.
Posted May 08, 2025 - 05:52 UTC
This scheduled maintenance affected: Production Environment - Global (Acquirers/Gateways Performance) and Production Environment - Saudi Arabia (Acquirers/Gateways Performance).