Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 19, 2025 - 21:01 UTC
Scheduled
MADA will perform a scheduled maintenance for below entities as per mentioned time intervals:
Entity Name Start Time End Time Alrajhi pay 21:00 UTC, 19 May 2025 01:00 UTC, 20 May 2025 Alrajhi Bank 23:00 UTC, 19 May 2025 01:00 UTC, 20 May 2025 Gulf International bank 00:30 UTC, 20 May 2025 03:00 UTC, 20 May 2025
During the scheduled maintenance window, customers may experience an intermittent failure in the ecommerce transactions.
Posted May 19, 2025 - 01:42 UTC
This scheduled maintenance affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).