Intermittent transaction failure detected

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent transaction failure on below 2 environment of Noon Payment infrastructure as per mentioned duration.

Production Environment - Global
From 00:00 Hrs. UTC to 02:20 Hrs. UTC, 17 June 2025

Test Environment - Global
From 00:00 Hrs. UTC to 07:05 Hrs. UTC, 17 June 2025

We sincerely apologize for the inconvenience caused.

Services have been restored and working as expected.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 15:07 UTC

Update

Transaction processing has resumed and is currently functioning for Test Environment-Global as well

Our teams are actively monitoring the systems to ensure continued stability.

We will provide further updates as necessary.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 07:19 UTC

Monitoring

Transaction processing has resumed and is currently functioning for Production Environment-Global

Our teams are actively monitoring the systems to ensure continued stability.

We will provide further updates as necessary.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 05:39 UTC

Update

The team is actively working to mitigate the issue as a priority.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 03:20 UTC

Identified

The team have identified cause of issue and working to mitigate the issue on priority.

This is incident also affecting Noon payments Test Environment- Global

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 00:58 UTC

Update

This incident is affecting Noon payments Production Environment- Global

The team is working to mitigate the issue on priority.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 00:43 UTC

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 00:39 UTC

Investigating

We are observing intermittent transaction failures while processing the transactions.

The team is working to mitigate the issue as a priority.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 17, 2025 - 00:34 UTC
This incident affected: Test Environment (Test Environment - Global), Production Environment - Global (Noon Payments Infrastructure), and Production Environment - Saudi Arabia (Noon Payments Infrastructure).