Intermittent failure detected while submitting the transactions to Apple Pay payment gateway

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent failure while submitting the transactions to the Apple Pay payment gateway between 15:14 UTC - 17:01 UTC 16 May 2025.

The service has been restored and is working as expected.

Thank you for your patience and continued support.
Posted May 16, 2025 - 18:30 UTC

Monitoring

We are no longer seeing intermittent failure while submitting the transactions to the Apple Pay payment gateway.

We are continuing to monitor the issue and will advise about the restoration of service.

Thank you for your patience and continued support.
Posted May 16, 2025 - 18:14 UTC

Identified

The Apple Pay team has identified an issue with the service

The Apple Pay team is urgently working to mitigate the issue and to restore services for all the customers.

Please refer to the below link for more details about the incident.
https://www.apple.com/support/systemstatus/

We will post further updates from Apple Pay till resolution of the issue.

Thank you for your patience and continued support.
Posted May 16, 2025 - 17:35 UTC

Investigating

We are observing an intermittent failure while submitting the transactions to the Apple Pay payment gateway.

We will post further updates until the resolution of the issue.

Thank you for your patience and continued support.
Posted May 16, 2025 - 17:21 UTC
This incident affected: Production Environment - Global (Acquirers/Gateways Performance) and Production Environment - Saudi Arabia (Acquirers/Gateways Performance).