Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 17, 2025 - 21:00 UTC
Scheduled
MADA will perform a scheduled maintenance for below entities as per mentioned time intervals:
Entity Name Start Time End Time Alrajhi Bank 21:00 UTC, 17 April 2025 01:00 UTC, 18 April 2025 Arab National Bank 23:00 UTC, 17 April 2025 03:00 UTC, 18 April 2025 STC Bank 23:15 UTC, 17 April 2025 01:35 UTC, 18 April 2025 Banque Saudi Fransi 00:00 UTC, 18 April 2025 04:00 UTC, 18 April 2025 Aljazeera Bank 01:00 UTC, 18 April 2025 03:00 UTC, 18 April 2025 Saudi Awwal Bank 01:00 UTC, 18 April 2025 03:00 UTC, 18 April 2025 American Express 04:30 UTC, 18 April 2025 06:30 UTC, 18 April 2025
During the scheduled maintenance window, customers may experience an intermittent failure in the ecommerce transactions.
Posted Apr 14, 2025 - 12:45 UTC
This scheduled maintenance affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).