Intermittent transactions failure detected from STC pay (Non banking issuer)
Incident Report for noon payments
Resolved
The reported issue has been resolved in which customers may have experienced an intermittent decline from STC pay (non-bank issuer) while submitting the transactions between 10:40 - 11:54 UTC, 19 September 2024.

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Sep 19, 2024 - 12:30 UTC
Update
We are still observing intermittent declines from STC pay (non banking issuer) while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continues support.
Posted Sep 19, 2024 - 11:47 UTC
Investigating
We are observing an intermittent declines from STC pay (non banking issuer) while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continues support.
Posted Sep 19, 2024 - 10:51 UTC
This incident affected: Production Environment - Global Endpoints (Issuers) and Production Environment - KSA Endpoints (Issuers).