Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 10:00 UTC
Scheduled
Noon Payments team will be performing scheduled maintenance activity on the Saudi Arabia Test environment between 10:00 hrs. UTC - 10:30 hrs. UTC, 20 January 2026.
During the scheduled maintenance window, customers may experience intermittent drift in response and timeout while processing the requests.
Posted Jan 20, 2026 - 07:48 UTC
This scheduled maintenance affected: Noon Payments - Test (Saudi Arabia - Test).