The reported issue has been resolved in which customers may have experienced the intermittent latency and timeouts while submitting the transactions to Mastercard payment gateway service between 15:20 Hrs. UTC, to 19:28 UTC, 22 July 2026 .
The service has been restored and working as expected.
Thank you for your patience and continued support.
Posted Jul 22, 2026 - 20:32 UTC
Monitoring
We are no longer observing Intermittent latency and timeout while submitting the transaction to Mastercard payment gateway services from 19:28 UTC, 22 July 2026 .
Mastercard team continues to work towards the restoration.
We are also continuing to monitor the issue and will advise once we receive confirmation from Mastercard about restoration of services.
Thank you for your patience and continued support.
Posted Jul 22, 2026 - 19:47 UTC
Identified
Mastercard team has identified an intermittent latency and timeout while submitting the transactions.
We will post further updates once we receive the same from the Mastercard team.
Thank you for your patience and continued support
Posted Jul 22, 2026 - 18:48 UTC
Investigating
We are observing an intermittent latency and timeout while submitting the transactions to Mastercard payment gateway services.
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.