Intermittent 3DS authentication failure detected while submitting transactions to Mastercard Payment Gateway Services

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent 3DS Authentication failure while submitting transactions to Mastercard Payment Gateway Services between 10:45 - 11:23 Hrs. UTC, 30 November 2025.

Mastercard team confirmed that service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Nov 30, 2025 - 12:37 UTC

Identified

A service degradation has been identified for Mastercard Gateway in North America, Asia Pacific and Kingdom of Saudi Arabia regions.

Customers may experience EMV 3DS Authentication transaction failures from 10:45 Hrs. UTC, 30 November 2025.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Nov 30, 2025 - 11:50 UTC
This incident affected: Acquirers/Gateways.