This scheduled maintenance activity on Noon Payments infrastructure for the Global, Saudi Arabia, and Egypt production environments has been cancelled.
We will notify you with a new schedule once the activity is rescheduled.
Thank you for your understanding and continued support.
Posted Jun 09, 2026 - 16:39 UTC
Scheduled
The team will be performing a scheduled maintenance on Noon Payments infrastructure for the Global, Saudi Arabia, and Egypt production environments between 02:15 - 04:15 Hrs. UTC, 11 June 2026.
During the scheduled maintenance window, customers may experience delays or intermittent service disruption while submitting the requests.
Posted Jun 09, 2026 - 07:34 UTC
This scheduled maintenance affected: Noon Payments - Production (Global - Production, Saudi Arabia - Production, Egypt - Production).