The reported issue has been resolved in which customers may have experienced an increase in transaction timeouts and/or failed transactions to the Mastercard payment gateway service between 06:50 hrs. - 07:25 hrs. UTC, 08 January 2026.
Services have been restored and are working as expected.
Thank you for your patience and continued support.
Posted Jan 08, 2026 - 07:51 UTC
Identified
The Mastercard team has identified a service disruption in the Kingdom of Saudi Arabia (KSA) region starting from 06:50 UTC, 08 Jan 2026.
The Mastercard team updated that the issue is impacting authorization of transactions, and impacted customers may see an increase in transaction timeouts and/or failed transactions.
Mastercard teams are urgently working to mitigate the impact.
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.
Posted Jan 08, 2026 - 07:34 UTC
Investigating
We are observing an intermittent decline from the KSA issuers while submitting the transactions starting from 06:50 UTC, 08 Jan 2026.
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.
Posted Jan 08, 2026 - 07:12 UTC
This incident affected: Acquirers/Gateways and Issuers.