Intermittent failure detected while submitting the transactions to Mastercard payment gateway services
Incident Report for noon payments
Resolved
The reported issue has been resolved in which customers may have experienced failures while submitting transactions to Mastercard payment gateway service in the Saudi Arabia region between 15:51 - 16:20 UTC, 29 September 2024.

Mastercard team has confirmed that the service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Sep 29, 2024 - 16:41 UTC
Identified
A service disruption has been identified for Mastercard Payment Gateway Services in Kingdom of Saudi Arabia starting from 15:51 UTC, 29 September 2024.

Mastercard team is working towards mitigating the impact and are urgently investigating the underlying issue.

Customers may experience intermittent failures while submitting transactions to Mastercard payment gateway service in Kingdom of Saudi Arabia.

We will post further updates from Mastercard till resolution of issue.

Thank you for your patience and continued support.
Posted Sep 29, 2024 - 16:22 UTC
This incident affected: Production Environment - KSA Endpoints (Acquirers/Gateways Performance).