Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 23:00 UTC
Scheduled
MADA will be performing a scheduled maintenance activity from 23:00 Hrs. UTC 18 June 2025 to 01:00 Hrs. UTC 19 June 2025. During the scheduled maintenance window, customers may experience intermittent failure in transactions from First Abu Dhabi Bank.
Posted Jun 16, 2025 - 06:06 UTC
This scheduled maintenance affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).