Intermittent transactions failure detected from STC pay (Non banking issuer)

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent decline from STC Pay (non-banking issuer) while submitting the transactions between 15:01 - 15:25 Hrs. UTC, 12 May 2025.

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted May 12, 2025 - 15:41 UTC

Identified

We are observing intermittent declines from STC Pay (non-banking issuer) while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted May 12, 2025 - 15:20 UTC
This incident affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).