Intermittent failure detected while submitting the transactions to Mastercard payment gateway service

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced intermittent failures while submitting the transactions to Mastercard payment gateway services for the below-mentioned impact durations.

Durations on 14 April 2025.
1. From 17:05 to 17:11 UTC,
2. From 17:21 to 17:28 UTC,
3. From 17:37 to 17:42 UTC,
4. From 18:39 to 18:55 UTC,
5. From 19:09 to 19:15 UTC,
6. From 20:26 to 20:42 UTC,
7. From 21:04 to 21:11 UTC,
8. From 21:54 to 22:02 UTC,
9. From 22:06 to 22:10 UTC,
10. From 22:57 to 22:58 UTC,
11. From 23:30 to 23:32 UTC.

Durations on 15 April 2025.
1. From 00:30 to 00:36 UTC,
2. From 03:30 to 03:32 UTC.

The Mastercard team has confirmed that the services have been restored and are working as expected.

Thank you for your patience and continued support.
Posted Apr 15, 2025 - 05:24 UTC

Monitoring

We are no longer seeing intermittent failure while submitting the transactions to Mastercard payment gateway service.

We are continuing to monitor the issue and will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Apr 14, 2025 - 20:27 UTC

Investigating

We are observing intermittent failure while submitting the transactions to Mastercard payment gateway service.

We kept it under observation and will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Apr 14, 2025 - 17:56 UTC
This incident affected: Production Environment - Global (Acquirers/Gateways Performance) and Production Environment - Saudi Arabia (Acquirers/Gateways Performance).