Intermittent failure while submitting the transactions to Mastercard payment gateway services

Incident Report for noon payments

Resolved

There was an issue from Mastercard payment gateway service between 20:43 - 20:59 UTC, 14 June 2025.

During the issue customers may have experienced an intermittent failures while submitting the transactions.

Mastercard team has confirmed that the service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Jun 14, 2025 - 21:36 UTC

Monitoring

We are no longer seeing the intermittent declines from Alrajhi Bank card issuer while submitting the transactions.

We are continuing to monitor the issue and will post further updates till the resolution of the same.

Thank you for your patience and continued support.
Posted Jun 14, 2025 - 21:20 UTC

Investigating

We are observing an intermittent declines from Alrajhi Bank card issuer while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 14, 2025 - 20:51 UTC
This incident affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).