Intermittent transaction failures detected across Mastercard-issued cards

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent transaction timeouts and/or failed transactions when using Mastercard Issued Cards between 04:02 - 05:44 Hrs. UTC, 15 August 2026.

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Aug 15, 2026 - 06:14 UTC

Identified

Cybersource identified that a Financial Participant is experiencing a service disruption that may be impacting some cardholder's ability to make payments.

For more information, please refer to the official incident page:
https://status.cybersource.com/incidents/bxmg266thg01

Thank you for your patience and continued support.
Posted Aug 15, 2026 - 05:07 UTC

Update

Cybersource has detected an issue that is currently affecting Payment Gateway Processing.

Cybersource team investigating the cause and working urgently to resolve the issue.

For more information, please refer to the official incident page:
https://status.cybersource.com/incidents/bxmg266thg01

Thank you for your patience and continued support.
Posted Aug 15, 2026 - 04:59 UTC

Update

We are continuing to investigate this issue.
Posted Aug 15, 2026 - 04:53 UTC

Investigating

We are observing an intermittent decline from UAE issuers while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Aug 15, 2026 - 04:48 UTC
This incident affected: Acquirers/Gateways.