Intermittent transaction failure detected

Incident Report for noon payments

Resolved

The reported issue has been resolved in which intermittent failures while processing the transactions during the maintenance activity between below intervals
1. 00:07 Hrs. - 01:07 Hrs. UTC, 11 June 2025.
2. 01:20 Hrs. - 01:26 Hrs. UTC, 11 June 2025.

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Jun 11, 2025 - 02:03 UTC

Monitoring

We are no longer observing the intermittent transaction failures while processing the transactions.

We are continuing to monitor the issue and will post further updates till the restoration of the service.

Thank you for your patience and continued support.
Posted Jun 11, 2025 - 01:17 UTC

Investigating

We are observing intermittent transaction failures while processing the transactions due to the maintenance activity.

Team is working to mitigate the issue on priority.
 
We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 11, 2025 - 00:44 UTC
This incident affected: Production Environment - Global (Noon Payments Infrastructure) and Production Environment - Saudi Arabia (Noon Payments Infrastructure).