Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2025 - 23:00 UTC
Scheduled
MADA will perform a scheduled maintenance for below entities as per mentioned time intervals:
Entity Name Start Time End Time Alrajhi Bank 23:00 UTC, 11 April 2025 04:00 UTC, 12 April 2025 Riyadh Bank 23:00 UTC, 11 April 2025 00:00 UTC, 12 April 2025
During the scheduled maintenance window, customers may experience an intermittent failure in the ecommerce transactions.
Posted Apr 08, 2025 - 14:01 UTC
This scheduled maintenance affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).