The reported issue has been resolved in which customers may have experienced the intermittent transaction declines from KSA issuer banks between 09:37 - 10:43 Hrs. UTC, 27 April 2026.
The service has been restored and working as expected.
Thank you for your patience and continued support.
Posted Apr 27, 2026 - 11:13 UTC
Update
We are no longer observing intermittent declines from Alrajhi issuer bank, however declines are still persist for Riyad issuer bank
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.
Posted Apr 27, 2026 - 10:42 UTC
Investigating
We are observing an intermittent decline from the KSA issuers (Alrajhi and Riyad Bank) while submitting the transactions.
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.