The reported issue has been resolved in which customers may have experienced an intermittent transaction timeouts and/or failed transactions while submitting the transactions to the Mastercard payment gateway service in the Asia/Pacific and North America regions from 20:30 Hrs. UTC, 16 August 2026 to 00:22 Hrs. UTC, 17 August 2026
Mastercard team confirmed that the service has been restored and is working as expected.
Thank you for your patience and continued support.
Posted Aug 17, 2026 - 01:08 UTC
Identified
Mastercard identified a service degradation is ongoing for Mastercard Gateway in the North America and Asia/Pacific regions.
Impacted customers may see an increase in transaction timeouts and/or failed transactions.
We will post further updates once we receive the same from the Mastercard team.
Thank you for your patience and continued support.
Posted Aug 16, 2026 - 23:22 UTC
Investigating
We are observing an intermittent latency and failure while submitting the transactions to Mastercard payment gateway services.
We will post further updates till the resolution of the issue.
Thank you for your patience and continued support.