There was an issue with Mastercard Checkout Services (MACS) between 18:30 - 21:59 UTC, 20 March 2025.
During the issue, customers may have experienced intermittent checkout failures.
The Mastercard team has confirmed that the services have been restored and are working as expected.
Thank you for your patience and continued support.
Posted Mar 20, 2025 - 23:13 UTC
Identified
A service disruption has been identified for Mastercard Checkout Services (MACS).
Customers may experience intermittent checkout transactions failures.
We will post further updates once we receive the same from the Mastercard team.
Thank you for your patience and continued support.
Posted Mar 20, 2025 - 21:09 UTC
This incident affected: Production Environment - Global (Acquirers/Gateways Performance) and Production Environment - Saudi Arabia (Acquirers/Gateways Performance).